Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Can't uninstall plug-in in eclipse-3.4
Can't uninstall plug-in in eclipse-3.4 [message #335764] Tue, 28 April 2009 09:33
Prasanna K is currently offline Prasanna K
Messages: 78
Registered: July 2009
Member
Hello,

I am running eclipse-3.4 on Windows XP.
Uninstall of my plug-in using eclipse-3.4 update manager ("Software
updates and Add-ons" window) is not working.

On a fresh eclipse-3.4 installation, I tried all this :
I installed my plug-in in eclipse-3.4 this way :
Help-> software updates - > Add site -> Local -> point to my update site
project.
Press ok -> restart? - > Yes.
The plug-in gets installed very well and works fine.

I try to uninstall my plug-in by doing this :
Help-> software updates - > Installed Software -> right click my plug-in ->
select uninstall.. Eclipse-3.4 asked me if it's ok to restart. I say yes.
Eclipse closes and comes back up. But I find my plug-in to be still there.

I tried out different operations on my plug-in with drop-down,
perspective, shortcut menus, etc. And it all works like before. That means
my plug-in wasn't uninstalled at all.

I closed eclipse and went to the directory :
eclipse-3.4-install-dir/plugins. There I found my plug-in's jar. I deleted
it and started eclipse with -clean option and my plug-in is gone. Great.
But when I tried to install my plug-in by the above said method, I got a
message saying : "Install has encountered a problem. An error occurred
during provisioning." When I clicked Details button I saw the message :
"Error reading signed content. The file
eclipse-3.4-install-dir/plugins/myplug-in.jar does not exist."
I restored the earlier deleted jar manually and restarted eclipse with
-clean option and found the plug-in right there.

I did search for a solution using google and found following links which
have no solutions provided in them.

http://dev.eclipse.org/newslists/news.eclipse.technology.equ inox/msg05730.html
http://dev.eclipse.org/newslists/news.eclipse.platform/msg76 525.html
http://dev.eclipse.org/newslists/news.eclipse.platform/msg74 515.html
http://dev.eclipse.org/newslists/news.eclipse.platform/msg76 472.html

Other things I have tried with same result :
Window>Preferences>General>Capabilities-> check Classic Update -> Apply -> ok.
Help -> Software Updates -> Manage Configuration -> Right click my plug-in
-> disable -> For the dialog Restart? -> Yes.
Eclipse-3.4 comes back up but my plug-in is far from disabled as it works
normally.

So, what is the procedure to uninstall a plug-in in eclipse-3.4?

Thanks.
Previous Topic:How to switch off automatic perspective switching?
Next Topic:[DataBindings] How to create a heterogeneous list of observables?
Goto Forum:
  


Current Time: Wed Jul 30 21:25:45 EDT 2014

Powered by FUDForum. Page generated in 0.01467 seconds