Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Software Updates in eclipse 3.4
Software Updates in eclipse 3.4 [message #333925] Wed, 14 January 2009 09:35 Go to next message
Sheela is currently offline Sheela
Messages: 52
Registered: July 2009
Member
Hi,

We have a feature based product on eclipse 3.4. Can someone tell me how to
configure it so as to provide software updates.

I have the update plugin and site.xml, and these worked fine on eclipse
3.3.2. But now when i try the software updates link in Help i get the
message
"Cannot launch the Update UI. This installation has not been configured
properly for software updates." How do i configure my product for software
updates?

I'm also getting the message
"!ENTRY org.eclipse.equinox.p2.ui.sdk 2 0 2009-01-14 14:57:46.318
!MESSAGE Could not locate the running profile instance" in the error log
view of the product. I think it is related to the same problem.

Please help

Thanks in advance,
Sheela
Re: Software Updates in eclipse 3.4 [message #333948 is a reply to message #333925] Wed, 14 January 2009 16:05 Go to previous messageGo to next message
Eclipse User
Originally posted by: eclipse-news.rizzoweb.com

On 1/14/2009 4:35 AM, Sheela wrote:
> Hi,
>
> We have a feature based product on eclipse 3.4. Can someone tell me how
> to configure it so as to provide software updates.
>
> I have the update plugin and site.xml, and these worked fine on eclipse
> 3.3.2. But now when i try the software updates link in Help i get the
> message "Cannot launch the Update UI. This installation has not been
> configured properly for software updates." How do i configure my product
> for software updates?
>
> I'm also getting the message "!ENTRY org.eclipse.equinox.p2.ui.sdk 2 0
> 2009-01-14 14:57:46.318
> !MESSAGE Could not locate the running profile instance" in the error log
> view of the product. I think it is related to the same problem.

If you Google for some of that text, you'll find lots of relevant
information. For example, "This installation has not been configured
properly for software updates" (with the quotes) leads to several blogs
and discussions.

Eric
Re: Software Updates in eclipse 3.4 [message #334033 is a reply to message #333948] Fri, 16 January 2009 06:54 Go to previous messageGo to next message
Sheela is currently offline Sheela
Messages: 52
Registered: July 2009
Member
Hi,

I have been through all the sites, but im still confused about how to
apply all these to my product.

Do i have to p2ize the eclipse im using, or the IDE i have made based on
eclipse.

Can someone give me a step by step guide ?

Thanks in advance

Regards,
Sheela
Re: Software Updates in eclipse 3.4 [message #504293 is a reply to message #334033] Fri, 18 December 2009 01:02 Go to previous message
Li Junhong is currently offline Li Junhong
Messages: 1012
Registered: July 2009
Senior Member
Hi Sheela,

Have you solved this problem of how to make update function available in exported RCP product based on eclipse 3.4?

Autually, it works really well based eclipse 3.3, just like the situation you met, but cannot work based on 3.4. I'm just a bit confused. Could you do me a favor to share your experience about this? Thanks so much!

Calvin.

[Updated on: Fri, 18 December 2009 01:03]

Report message to a moderator

Previous Topic:"Paste" action redefinition not complete.
Next Topic:Automatic updates of Launch Configuration
Goto Forum:
  


Current Time: Sun Sep 21 06:15:54 GMT 2014

Powered by FUDForum. Page generated in 0.07836 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software