Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » problem exporting a plugin
problem exporting a plugin [message #333165] Thu, 27 November 2008 09:15 Go to next message
Eclipse UserFriend
Originally posted by: luimarr1.upvnet.upv.es

Hi all,

I´m trying to export a plugin. It basically is the schema_editor gef
example with some modifications. The problem comes when I open the
export wizard for export it as a deployable plugin, the plugin does not
appear in the 'Available plugins and fragments' list.
Any idea of where am i mistaken??? (I already created the manifest and
so on)

Thanks in advances,

L.Marco
icon3.gif  Re: problem exporting a plugin [message #539527 is a reply to message #333165] Fri, 11 June 2010 08:13 Go to previous message
Rolf Wojtech is currently offline Rolf WojtechFriend
Messages: 2
Registered: June 2010
Junior Member
I had the same problem (My plug-in does not show in Deployable plug-ins and fragments list) and I found the solution. I realize your question is very old and you won't need the answer anymore but it may help others who work on old plug-ins.

Anyways, the reason (for me) was a lack of a build.properties file. I copied one from a freshly generated plug-in and it immediately showed in the 'Available Plug-ins and Fragments' list.

I also added the natures from the generated plug-in but that may not have been necessary.

Previous Topic:Key binding conflict with "Undefined Command"
Next Topic:Managing API-Leaks
Goto Forum:
  


Current Time: Sat Dec 20 19:33:58 GMT 2014

Powered by FUDForum. Page generated in 0.01559 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software