Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » A different problem running Eclipse Ganymede on Ubuntu Gutsy Gibbon
A different problem running Eclipse Ganymede on Ubuntu Gutsy Gibbon [message #330739] Tue, 12 August 2008 14:08 Go to next message
Eclipse User
Originally posted by: fogartyrb.gmail.com

I too am having problems running Eclipse Ganymede on Ubuntu Gutsy Gibbon.

I don't have gcj installed. I have tried both
jdk1.5.0_15 and jdk1.6.0_10. Specifically builds:

java version "1.5.0_15"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_15-b04)
Java HotSpot(TM) Server VM (build 1.5.0_15-b04, mixed mode)

and

java version "1.6.0_10-rc"
Java(TM) SE Runtime Environment (build 1.6.0_10-rc-b28)
Java HotSpot(TM) Server VM (build 11.0-b15, mixed mode)


When I launch eclipse (with or without the -vm option). I get the
following in workspace/.metadata/.log:

!SESSION 2008-08-12 08:39:23.072
-----------------------------------------------
eclipse.buildId=I20080617-2000
java.version=1.5.0_15
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.ui 4 0 2008-08-12 08:39:27.073
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException
at
org.eclipse.jface.resource.FileImageDescriptor.getFilePath(F ileImageDescriptor.java:219)
at
org.eclipse.jface.resource.FileImageDescriptor.createImage(F ileImageDescriptor.java:172)
at
org.eclipse.jface.resource.ImageDescriptor.createImage(Image Descriptor.java:227)
at
org.eclipse.jface.resource.ImageDescriptor.createImage(Image Descriptor.java:205)
at org.eclipse.jface.action.StatusLine.<init>(StatusLine.java:286)
at
org.eclipse.jface.action.StatusLineManager.createControl(Sta tusLineManager.java:99)
at
org.eclipse.ui.presentations.AbstractPresentationFactory.cre ateStatusLineControl(AbstractPresentationFactory.java:125)
at
org.eclipse.ui.internal.WorkbenchWindow.createStatusLine(Wor kbenchWindow.java:3800)
at
org.eclipse.ui.internal.WorkbenchWindow.createDefaultContent s(WorkbenchWindow.java:1082)
at
org.eclipse.ui.internal.WorkbenchWindowConfigurer.createDefa ultContents(WorkbenchWindowConfigurer.java:625)
at
org.eclipse.ui.application.WorkbenchWindowAdvisor.createWind owContents(WorkbenchWindowAdvisor.java:268)
at
org.eclipse.ui.internal.WorkbenchWindow.createContents(Workb enchWindow.java:998)
at org.eclipse.jface.window.Window.create(Window.java:431)
at
org.eclipse.ui.internal.Workbench$20.runWithException(Workbe nch.java:1014)
at
org.eclipse.ui.internal.StartupThreading$StartupRunnable.run (StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:133)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3378)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3036)
at
org.eclipse.ui.application.WorkbenchAdvisor.openWindows(Work benchAdvisor.java:803)
at
org.eclipse.ui.internal.Workbench$27.runWithException(Workbe nch.java:1361)
at
org.eclipse.ui.internal.StartupThreading$StartupRunnable.run (StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:133)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3378)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3036)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2293)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 98)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:288)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:488)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:382)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

If anyone has any ideas I would be very appreciated. Note, I had it
running but then I did install KDE stuff and some extra gtk and qt stuff
to get the latest Kvpnc running and Konqueror.

Thank you,
Ryan Fogarty
Oops that was on Ubuntu Hardy Heron not Gutsy Gibbon [message #330745 is a reply to message #330739] Tue, 12 August 2008 14:12 Go to previous messageGo to next message
Eclipse User
Originally posted by: fogartyrb.gmail.com

Please excuse mind-slip that is Ubuntu Hardy Heron.

Thanks again,
Ryan
Re: A different problem running Eclipse Ganymede on Ubuntu Gutsy Gibbon [message #550078 is a reply to message #330739] Thu, 29 July 2010 05:12 Go to previous message
Consuelo Franky is currently offline Consuelo Franky
Messages: 1
Registered: July 2010
Junior Member
I have the same exception message trying to open a xhmtl page with the JBoss Tool HTML editor.

My environment is Eclipse Ganymede with JBoss Tools 3.0.2 GA in Windows XP.

Have you found some solution to your problem ?

Any information is appreciated.
Previous Topic:Ignoring Eclipse build/builders when modifying project structure/classpath
Next Topic:history view doesn't display items
Goto Forum:
  


Current Time: Thu Sep 18 19:54:49 GMT 2014

Powered by FUDForum. Page generated in 0.06622 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software