Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Migration from Polarion version to Eclipse version fails with Eclipse 3.3
Migration from Polarion version to Eclipse version fails with Eclipse 3.3 [message #31778] Wed, 13 August 2008 16:10 Go to next message
Thorsten  Möller is currently offline Thorsten MöllerFriend
Messages: 23
Registered: July 2009
Junior Member
Hello,

I'm still using Eclipse 3.3 and wanted to upgrade Subversive from the
Polarion version (SVN Team Provider 1.1.9.02) to the most current Eclipse
version (Subversive SVN Team Provider 0.7.3). I followed the migration
instructions
http://www.eclipse.org/subversive/documentation/gettingStart ed/aboutSubversive/update_polarion.php
and did the following steps in this order:

1.) Install Subversive SVN Team Provider 0.7.3 via archived update site
downloaded from
http://www.eclipse.org/downloads/download.php?file=/technolo gy/subversive/0.7/builds/Subversive-incubation-0.7.3.I200808 14-1500.zip

Note that the Polarion version was not uninstalled (as the instructions
document indicates).

2.) Restart Eclipse and try to click 'Help > Subversive > Migrate Projects
and Settings'. The result is that a dialog window pops up saying "The chosen
operation is not currently available". In the error log appears a new event
and stack trace as appended at the end of this message.

I also tried to disable the Polarion version (including all its
dependencies), restart Eclipse, and try the same action. The effect is the
same.

Any hints what I can do now?

Best,
Thorsten








Error
Wed Aug 13 17:24:35 CEST 2008
Plug-in org.eclipse.team.svn.ui was unable to load class
org.eclipse.team.svn.ui.debugmail.MigrateToEclipse.

org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter $TerminatingClassNotFoundException:
An error occurred while automatically activating bundle
org.eclipse.team.svn.ui (628).
at
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .postFindLocalClass(EclipseLazyStarter.java:125)
at
org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClass(ClasspathManager.java:417)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.fin dLocalClass(DefaultClassLoader.java:189)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findLo calClass(BundleLoader.java:340)
at
org.eclipse.osgi.framework.internal.core.SingleSourcePackage .loadClass(SingleSourcePackage.java:37)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl assInternal(BundleLoader.java:405)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:369)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:357)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:83)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at
org.eclipse.team.svn.mylyn.SVNActiveChangeSetProvider.getAct iveChangeSetManager(SVNActiveChangeSetProvider.java:25)
at
org.eclipse.mylyn.internal.team.ui.FocusedTeamUiPlugin.addAc tiveChangeSetProvider(FocusedTeamUiPlugin.java:124)
at
org.eclipse.mylyn.internal.team.ui.FocusedTeamExtensionPoint Reader.readExtensions(FocusedTeamExtensionPointReader.java:5 0)
at
org.eclipse.mylyn.internal.team.ui.FocusedTeamUiPlugin$1.run (FocusedTeamUiPlugin.java:77)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:129)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3659)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3296)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2389)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:22 19)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:289)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:461)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:106)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:169)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:106)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:76)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:363)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
Caused by: org.osgi.framework.BundleException: The activator
org.eclipse.team.svn.ui.SVNTeamUIPlugin for bundle org.eclipse.team.svn.ui
is invalid
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:970)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
at
org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
at
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .postFindLocalClass(EclipseLazyStarter.java:111)
... 38 more
Caused by: java.lang.NoClassDefFoundError:
org/eclipse/team/svn/core/operation/IActionOperation
at org.eclipse.team.svn.ui.SVNTeamUIPlugin.<init>(SVNTeamUIPlugin.java:54)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Nativ e Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknow n Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Un known
Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:136)
... 43 more
Caused by:
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter $TerminatingClassNotFoundException:
An error occurred while automatically activating bundle
org.eclipse.team.svn.core (624).
at
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .postFindLocalClass(EclipseLazyStarter.java:125)
at
org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLoc alClass(ClasspathManager.java:417)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.fin dLocalClass(DefaultClassLoader.java:189)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findLo calClass(BundleLoader.java:340)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl assInternal(BundleLoader.java:408)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:369)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findCl ass(BundleLoader.java:357)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loa dClass(DefaultClassLoader.java:83)
at java.lang.ClassLoader.loadClass(Unknown Source)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.loadCl ass(BundleLoader.java:289)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClas s(BundleHost.java:227)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load Class(AbstractBundle.java:1269)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI .createExecutableExtension(RegistryStrategyOSGI.java:160)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createE xecutableExtension(ExtensionRegistry.java:788)
at
org.eclipse.core.internal.registry.ConfigurationElement.crea teExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandl e.createExecutableExtension(ConfigurationElementHandle.java: 51)
at
org.eclipse.team.core.RepositoryProvider.newProvider(Reposit oryProvider.java:706)
at
org.eclipse.team.core.RepositoryProvider.mapNewProvider(Repo sitoryProvider.java:162)
at
org.eclipse.team.core.RepositoryProvider.mapExistingProvider (RepositoryProvider.java:235)
at
org.eclipse.team.core.RepositoryProvider.getProvider(Reposit oryProvider.java:577)
at
org.eclipse.team.svn.ui.decorator.wrapper.AbstractDecoratorW rapper.isSVNShared(AbstractDecoratorWrapper.java:39)
at
org.eclipse.team.svn.ui.decorator.wrapper.ProjectDecoratorWr apper.decorate(ProjectDecoratorWrapper.java:27)
at
org.eclipse.ui.internal.decorators.LightweightDecoratorDefin ition.decorate(LightweightDecoratorDefinition.java:253)
at
org.eclipse.ui.internal.decorators.LightweightDecoratorManag er$LightweightRunnable.run(LightweightDecoratorManager.java: 71)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.runtime.Platform.run(Platform.java:857)
at
org.eclipse.ui.internal.decorators.LightweightDecoratorManag er.decorate(LightweightDecoratorManager.java:336)
at
org.eclipse.ui.internal.decorators.LightweightDecoratorManag er.getDecorations(LightweightDecoratorManager.java:322)
at
org.eclipse.ui.internal.decorators.DecorationScheduler$1.ens ureResultCached(DecorationScheduler.java:369)
at
org.eclipse.ui.internal.decorators.DecorationScheduler$1.run (DecorationScheduler.java:329)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Caused by: org.osgi.framework.BundleException: Exception in
org.eclipse.team.svn.core.SVNTeamPlugin.start() of bundle
org.eclipse.team.svn.core.
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tartActivator(BundleContextImpl.java:1018)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:974)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:260)
at
org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
at
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .postFindLocalClass(EclipseLazyStarter.java:111)
... 30 more
Caused by: java.io.StreamCorruptedException: invalid type code: 00
at java.io.ObjectInputStream.readObject0(Unknown Source)
at java.io.ObjectInputStream.readObject(Unknown Source)
at
org.eclipse.team.svn.core.svnstorage.AbstractSVNStorage.load LocationsFromFile(AbstractSVNStorage.java:548)
at
org.eclipse.team.svn.core.svnstorage.AbstractSVNStorage.init ializeImpl(AbstractSVNStorage.java:402)
at
org.eclipse.team.svn.core.svnstorage.SVNRemoteStorage.initia lize(SVNRemoteStorage.java:163)
at org.eclipse.team.svn.core.SVNTeamPlugin.start(SVNTeamPlugin. java:154)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$2 .run(BundleContextImpl.java:999)
at java.security.AccessController.doPrivileged(Native Method)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tartActivator(BundleContextImpl.java:993)
... 35 more
Re: Migration from Polarion version to Eclipse version fails with Eclipse 3.3 [message #32023 is a reply to message #31778] Fri, 15 August 2008 23:12 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: spam.raphael.comcast.net

I get exactly the same error in the <workspace>/.metedata/.logs after
installing the subversive plugins into eclipse 3.2. I am using Windows
XP. I also tried installing eclipse 3.4.0 and then installing subversive
(version I20080814-1500)

I get the same error with both eclipses.


Caused by: org.osgi.framework.BundleException: The activator
org.eclipse.team.svn.ui.SVNTeamUIPlugin for bundle org.eclipse.team.svn.ui
is invalid
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:146)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.s tart(BundleContextImpl.java:980)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:346)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.star t(AbstractBundle.java:265)
at
org.eclipse.osgi.framework.util.SecureAction.start(SecureAct ion.java:400)
at
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter .postFindLocalClass(EclipseLazyStarter.java:111)
... 73 more
Caused by: java.lang.NoClassDefFoundError:
org/eclipse/team/svn/core/operation/IActionOperation
at org.eclipse.team.svn.ui.SVNTeamUIPlugin.<init>(SVNTeamUIPlugin.java:54)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Nativ e Method)
at
sun.reflect.NativeConstructorAccessorImpl.newInstance(Native ConstructorAccessorImpl.java:39)
at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(De legatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:4 94)
at java.lang.Class.newInstance0(Class.java:350)
at java.lang.Class.newInstance(Class.java:303)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.load BundleActivator(AbstractBundle.java:141)
Re: Migration from Polarion version to Eclipse version fails with Eclipse 3.3 [message #32057 is a reply to message #32023] Fri, 15 August 2008 23:31 Go to previous message
Eclipse UserFriend
Originally posted by: spam.raphael.comcast.net

I just tried creating a new workspace and importing the svn project. This
worked.
Previous Topic:change sets and create patch problem
Next Topic:svn: This client is too old to work with working copy '...'; please get a newer Subversion client ?$
Goto Forum:
  


Current Time: Mon Nov 24 12:18:46 GMT 2014

Powered by FUDForum. Page generated in 0.16445 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software