Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Target Management » Hang while loading workspace, possibly related to Target Management.
Hang while loading workspace, possibly related to Target Management. [message #31570] Wed, 28 January 2009 13:32 Go to next message
Robin Fernandes is currently offline Robin Fernandes
Messages: 5
Registered: July 2009
Junior Member
Hi all,

When restarting after an unclean shutdown (e.g. after Eclipse has crashed
or after I have terminated the process without exiting correctly), I often
find Eclipse hangs while loading my workspace.

I think this may be related to the Target Management plugin: the only way
I have found to successfully load up my workspace again is to temporarily
remove the Target Management metadata from my workspace, i.e.
<workspace>/.metadata/.plugins/org.eclipse.rse.*.

After one successful startup, I can then stop Eclipse, copy my original TM
metadata back to my workspace, start Eclipse again, and continue working
as usual.

Here is a Java dump taken during the hang on startup:
http://soal.org/eclipse/javacore.20090128.175548.4524.0002.t xt

Here are my Eclipse configuration details:
http://soal.org/eclipse/configDetails.txt

Do you have any thoughts on what might be causing this or on how I could
avoid this?

Regards,
Robin
Re: Hang while loading workspace, possibly related to Target Management. [message #31638 is a reply to message #31570] Sun, 01 February 2009 21:40 Go to previous message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 983
Registered: July 2009
Senior Member
Hi Robin,

there are some existing bugs in bugzilla that might be related.
Are you using EFS linked resources?

At any rate, please file a bug in bugzilla with the information
you have provided, this will allow us to track this much better:
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Target%2 0Management&component=RSE

Thanks,
--
Martin Oberhuber, Senior Member of Technical Staff, Wind River
Target Management Project Lead, DSDP PMC Member
http://www.eclipse.org/dsdp/tm




Robin Fernandes wrote:
> Hi all,
>
> When restarting after an unclean shutdown (e.g. after Eclipse has
> crashed or after I have terminated the process without exiting
> correctly), I often find Eclipse hangs while loading my workspace.
>
> I think this may be related to the Target Management plugin: the only
> way I have found to successfully load up my workspace again is to
> temporarily remove the Target Management metadata from my workspace,
> i.e. <workspace>/.metadata/.plugins/org.eclipse.rse.*.
>
> After one successful startup, I can then stop Eclipse, copy my original
> TM metadata back to my workspace, start Eclipse again, and continue
> working as usual.
>
> Here is a Java dump taken during the hang on startup:
> http://soal.org/eclipse/javacore.20090128.175548.4524.0002.t xt
>
> Here are my Eclipse configuration details:
> http://soal.org/eclipse/configDetails.txt
>
> Do you have any thoughts on what might be causing this or on how I could
> avoid this?
>
> Regards,
> Robin
>
Re: Hang while loading workspace, possibly related to Target Management. [message #578867 is a reply to message #31570] Sun, 01 February 2009 21:40 Go to previous message
Martin Oberhuber is currently offline Martin Oberhuber
Messages: 983
Registered: July 2009
Senior Member
Hi Robin,

there are some existing bugs in bugzilla that might be related.
Are you using EFS linked resources?

At any rate, please file a bug in bugzilla with the information
you have provided, this will allow us to track this much better:
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Target%2 0Management&component=RSE

Thanks,
--
Martin Oberhuber, Senior Member of Technical Staff, Wind River
Target Management Project Lead, DSDP PMC Member
http://www.eclipse.org/dsdp/tm




Robin Fernandes wrote:
> Hi all,
>
> When restarting after an unclean shutdown (e.g. after Eclipse has
> crashed or after I have terminated the process without exiting
> correctly), I often find Eclipse hangs while loading my workspace.
>
> I think this may be related to the Target Management plugin: the only
> way I have found to successfully load up my workspace again is to
> temporarily remove the Target Management metadata from my workspace,
> i.e. <workspace>/.metadata/.plugins/org.eclipse.rse.*.
>
> After one successful startup, I can then stop Eclipse, copy my original
> TM metadata back to my workspace, start Eclipse again, and continue
> working as usual.
>
> Here is a Java dump taken during the hang on startup:
> http://soal.org/eclipse/javacore.20090128.175548.4524.0002.t xt
>
> Here are my Eclipse configuration details:
> http://soal.org/eclipse/configDetails.txt
>
> Do you have any thoughts on what might be causing this or on how I could
> avoid this?
>
> Regards,
> Robin
>
Previous Topic:Call for participation: TM 3.1m5 test pass on 1-Feb-2009
Next Topic:'Invalid Project Description' when using RSE file system
Goto Forum:
  


Current Time: Fri Aug 22 17:44:12 EDT 2014

Powered by FUDForum. Page generated in 0.04634 seconds