Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » Re: OCL plugin
Re: OCL plugin [message #31369] Fri, 29 June 2007 07:56 Go to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

This is a multi-part message in MIME format.
--------------000207010508010302060205
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Marina,

You'd be best to use the OCL newsgroup, which I've added to the "to"
list of this reply.

The org.eclipse.ui.ide should come installed in Eclipse itself and
org.eclipse.emf.ecore should come from the appropriate EMF install.
What versions numbers of these are you trying to install and in which
version of Eclipse? The GA versions of all these will be available
today (in maybe an hour or so). I assume you have a 5.0 JVM, because
EMF 2.3 won't work without that. And I assume you've run eclipse.exe
-clean if you are installing by unzipping the zipped distributions.
Using the Europa update site when it goes live with the GA versions
shortly is probably easiest:
<http://www.eclipse.org/europa/>

http://www.eclipse.org/europa/


Marina wrote:
> Hello to everybody!
>
> My problem is that I want to get the OCL eclipse plugin working, I
> have tried the three last versions of emf sdk to get it installed and
> I always receive an error message of one of these kinds:
> "Configuration problem"
> "Some plugin is missed:"
> org.eclipse.emf.ecore or org.eclipse.ui.ide
> I included the first one but the second one is not findable surfing
> the net.
>
> Anyway, could someone send all the files I would need for running the
> plugin to me (I only want to test its functionalities!!) and a
> "step-by-step" installation algorithm of what I have to do to be able
> to use the plugin?
>
> As I said, I don't want (by now) to develop anything but to test the
> "goodness" of the OCL tool.
>
> Thank you very much!!!
> Best Regards!
>
>


--------------000207010508010302060205
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Marina,<br>
<br>
You'd be best to use the OCL newsgroup, which I've added to the "to"
list of this reply.<br>
<br>
The org.eclipse.ui.ide should come installed in Eclipse itself and
org.eclipse.emf.ecore should come from the appropriate EMF install.
Re: OCL plugin [message #31452 is a reply to message #31369] Fri, 29 June 2007 09:56 Go to previous message
Eclipse User
Originally posted by: cdamus.ca.ibm.com

Hi, Marina, Ed,

The only thing that I can add to Ed's excellent reply is that the
org.eclipse.ui.ide plug-in is included in the Eclipse *SDK* download, not
the Eclipse Platform. The first of the special packages on the
http://www.eclipse.org/downloads/ should have what you need.

Cheers,

Christian


Ed Merks wrote:

> Marina,
>
> You'd be best to use the OCL newsgroup, which I've added to the "to"
> list of this reply.
>
> The org.eclipse.ui.ide should come installed in Eclipse itself and
> org.eclipse.emf.ecore should come from the appropriate EMF install.
> What versions numbers of these are you trying to install and in which
> version of Eclipse? The GA versions of all these will be available
> today (in maybe an hour or so). I assume you have a 5.0 JVM, because
> EMF 2.3 won't work without that. And I assume you've run eclipse.exe
> -clean if you are installing by unzipping the zipped distributions.
> Using the Europa update site when it goes live with the GA versions
> shortly is probably easiest:
> <http://www.eclipse.org/europa/>
>
> http://www.eclipse.org/europa/
>
>
> Marina wrote:
>> Hello to everybody!
>>
>> My problem is that I want to get the OCL eclipse plugin working, I
>> have tried the three last versions of emf sdk to get it installed and
>> I always receive an error message of one of these kinds:
>> "Configuration problem"
>> "Some plugin is missed:"
>> org.eclipse.emf.ecore or org.eclipse.ui.ide
>> I included the first one but the second one is not findable surfing
>> the net.
>>
>> Anyway, could someone send all the files I would need for running the
>> plugin to me (I only want to test its functionalities!!) and a
>> "step-by-step" installation algorithm of what I have to do to be able
>> to use the plugin?
>>
>> As I said, I don't want (by now) to develop anything but to test the
>> "goodness" of the OCL tool.
>>
>> Thank you very much!!!
>> Best Regards!
>>
>>
Previous Topic:Re: Multiple metamodels not supported?
Next Topic:stereotype missing: invariant/postcondition/precondition
Goto Forum:
  


Current Time: Fri Apr 18 06:46:56 EDT 2014

Powered by FUDForum. Page generated in 0.02804 seconds