Skip to main content
October Donation Campaign Donate Now

Adopting 4.3 mechanisms and APIs

This section describes changes that are required if you are trying to change your 4.2 plug-in to adopt the 4.3 mechanisms and APIs.

  1. Ensure all plug-ins include an OSGi manifest

1. Ensure all plug-ins include an OSGi manifest

The Eclipse platform 4.3 release is the final release that will support 2.x style Eclipse plug-ins with no OSGi manifest file (MANIFEST.MF). A warning will now be logged when such plug-ins are encountered, with a log entry like this:

The plugin "com.acme.ancient.plugin" with the version "1.0.1" is an old style Eclipse 2.0 
plugin with no OSGi bundle manifest. Support for Eclipse 2.0 style plugins will be removed in a future release.

If you see such a log entry for your plug-in, you must migrate now. Migrate by clicking the link in the plug-in manifest editor entitled, "create an OSGi bundle manifest." For more details see bug 407312.

Back to the top