Customize Your Callisto Experience

The Callisto Experience starts with a small download in the form of the Eclipse Platform Runtime Binaries. From this starting point, using the Callisto Discovery Site, you can add as few or as many of the features produced by the ten projects involved in the Callisto release train as you need.

What do you need?

Eclipse 3.2 is required for Callisto. There is no upgrade path from previous versions of Eclipse.

  • The Eclipse Platform Runtime Binaries
  • Optional features available via the Callisto Discovery Site
    • C/C++ Development tools (CDT)
    • Data Tools (DTP)
    • Eclipse Modeling Framework (EMF)
    • Graphical Editing Framework (GEF)
    • Graphical Modeling Framework (GMF)
    • Java Development Tools (JDT)
    • Java EE and Web Tools (WTP)
    • Reporting Tools (BIRT)
    • Test and Performance Tools (TPTP)
    • Visual Editor (VE)